Wednesday, February 26, 2020

VoIP Multi Site : NAT

5
Configuration

 

5.1. Configuration du VRCasa :
VRCasa(Config)#access-list 101 permit ip 192.168.28.0 0.0.0.255 any
VRCasa(Config)#ip nat inside source list 101 interface serial0/0 overload
VRCasa(Config)#interface vlan 1
VRCasa(Config-if)#ip nat inside 
VRCasa(config)#exit
VRCasa(Config)#interface serial0/0
VRCasa(Config-if)#ip nat outside 
VRCasa(config)#exit
5.2. Configuration du VRRabat :
VRRabat(Config)#access-list 101 permit ip 192.168.111.0 0.0.0.255 any
VRRabat(Config)#ip nat inside source list 101 interface serial0/0 overload
VRRabat(Config)#interface vlan 1
VRRabat(Config-if)#ip nat inside 
VRRabat(config)#exit
VRRabat(Config)#interface serial0/0
VRRabat(Config-if)#ip nat outside 
VRRabat(config)#exit

VoIP Multi Site : Routing

4
Configuration

 

4.1. Configuration du VRCasa :
VRCasa(Config)#ip route 0.0.0.0 0.0.0.0 serial0/0
VRCasa(config)#exit
4.2. Configuration du ISPCasa :
ISPCasa(Config)#router ospf 100
ISPCasa(Config-router)#log-adjacency-changes 
ISPCasa(Config-router)#redistribute connected subnets 
ISPCasa(Config-router)#network 10.0.0.0 0.0.0.255 area 0
ISPCasa(Config-router)#exit
4.3. Configuration du ISPBB :
ISPBB(Config)#router ospf 100
ISPBB(Config-router)#log-adjacency-changes 
ISPBB(Config-router)#network 10.0.0.0 0.0.0.255 area 0
ISPBB(Config-router)#network 10.0.1.0 0.0.0.255 area 0
ISPBB(Config-router)#exit
4.4. Configuration du ISPRabat :
ISPRabat(Config)#router ospf 100
ISPRabat(Config-router)#log-adjacency-changes 
ISPRabat(Config-router)#redistribute connected subnets 
ISPRabat(Config-router)#network 10.0.1.0 0.0.0.255 area 0
ISPRabat(Config-router)#exit
4.5. Configuration du VRRabat :
VRRabat(Config)#ip route 0.0.0.0 0.0.0.0 serial0/0
VRRabat(config)#exit

VPN Multi Site : Adressage

 

Prerequisites:

  • GNS3 (in my case, the last release GNS3 1.4.1)
  • Cisco c3725-adventerprisek9-mz124-25.image

  • VMware vSwith (in my case, vmnet1 & vmnet3)

VoIPVMarevSwitch

1
Plan d'adressage
2
Configuration

 

2.1. Configuration des machines virtuelles :

Configuration des cartes reseaux des machines virtuelles sous VMware

2.2. Configuration du ESWCasa :
ESWCasa(Config)#interface vlan 1
ESWCasa(Config-if)#ip address 192.168.28.100 255.255.255.0
ESWCasa(Config-if)#no shutdown 
ESWCasa(Config-if)#exit
2.3. Configuration du VRCasa :
VRCasa(Config)#interface vlan 1
VRCasa(Config-if)#ip address 192.168.28.1 255.255.255.0
VRCasa(Config-if)#no shutdown 
VRCasa(Config-if)#exit
VRCasa(Config)#interface serial0/0
VRCasa(Config-if)#ip address 81.192.22.2 255.2555.255.252
VRCasa(Config-if)#no shutdown 
VRCasa(Config-if)#exit
2.4. Configuration du ISPCasa :
ISPCasa(Config)#interface serial0/1
ISPCasa(Config-if)#ip address 81.192.22.1 255.2555.255.252
ISPCasa(Config-if)#no shutdown 
ISPCasa(Config-if)#exit
ISPCasa(Config)#interface serial0/0
ISPCasa(Config-if)#ip address 10.0.0.2 255.2555.255.0
ISPCasa(Config-if)#no shutdown 
ISPCasa(Config-if)#exit
2.5. Configuration du ISPBB :
ISPBB(Config)#interface serial0/0
ISPBB(Config-if)#ip address 10.0.0.1 255.2555.255.0
ISPBB(Config-if)#no shutdown 
ISPBB(Config-if)#exit
ISPBB(Config)#interface serial0/1
ISPBB(Config-if)#ip address 10.0.1.1 255.2555.255.0
ISPBB(Config-if)#no shutdown 
ISPBB(Config-if)#exit
2.6. Configuration du ISPRabat :
ISPRabat(Config)#interface serial0/0
ISPRabat(Config-if)#ip address 10.0.1.2 255.2555.255.0
ISPRabat(Config-if)#no shutdown 
ISPRabat(Config-if)#exit
ISPRabat(Config)#interface serial0/1
ISPRabat(Config-if)#ip address 81.192.37.1 255.2555.255.252
ISPRabat(Config-if)#no shutdown 
ISPRabat(Config-if)#exit
2.7. Configuration du VRRabat :
VRRabat(Config)#interface serial0/0
VRRabat(Config-if)#ip address 81.192.37.2 255.2555.255.252
VRRabat(Config-if)#no shutdown 
VRRabat(Config-if)#exit
VRRabat(Config)#interface vlan 1
VRRabat(Config-if)#ip address 192.168.111.1 255.2555.255.0
VRRabat(Config-if)#no shutdown 
VRRabat(Config-if)#exit
2.8. Configuration du ESWRabat :
ESWRabat(Config)#interface vlan 1
ESWRabat(Config-if)#ip address 192.168.111.100 255.2555.255.0
ESWRabat(Config-if)#no shutdown 
ESWRabat(Config-if)#exit

VoIP Multi Site : DHCP

 

Prerequisites:

  • GNS3 (in my case, the last release GNS3 1.4.1)
  • Cisco c3725-adventerprisek9-mz124-25.image

  • VMware vSwith (in my case, vmnet1 & vmnet3)
1
Configuration

 

1.1. Configuration du VRCasa :
VRCasa(Config)#ip dhcp excluded-address 192.168.28.1 192.168.28.10
VRCasa(Config)#ip dhcp excluded-address 192.168.28.50 192.168.28.60
VRCasa(Config)#ip dhcp excluded-address 192.168.28.100 192.168.28.110
VRCasa(Config)#ip dhcp pool VoipLabPool
VRCasa(dhcp-config)#network 192.168.28.0
VRCasa(dhcp-config)#default-router 192.168.28.1
VRCasa(dhcp-config)#option 150 ip 192.168.28.1
VRCasa(dhcp-config)#exit
1.2. Configuration du VRRabat :
VRRabat(Config)#ip dhcp excluded-address 192.168.111.1 192.168.111.10
VRRabat(Config)#ip dhcp excluded-address 192.168.111.50 192.168.111.60
VRRabat(Config)#ip dhcp excluded-address 192.168.111.100 192.168.111.110
VRRabat(Config)#ip dhcp pool VoipLabPool
VRRabat(dhcp-config)#network 192.168.111.0
VRRabat(dhcp-config)#default-router 192.168.111.1
VRRabat(dhcp-config)#option 150 ip 192.168.111.1
VRRabat(dhcp-config)#exit

Cisco VoIP GNS3 Lab : Multi Site Architecture

1
Introduction







2
Architecture




VoIPArchitecture

GET IN TOUCH

ESSALIFI MOHAMED FAICAL
Rabat - Maroc/Morocco
+212 6 61 233 909

Email: This email address is being protected from spambots. You need JavaScript enabled to view it.
Skype: mf.essalifi

Scroll to top